Posteado por: Carlos JG | 25 octubre 2006

Beryl en Ubuntu Edgy con ATI

El artículo que buscas se encuentra en: http://www.elblogdemaverick.com/?p=12

El Blog de Maverick 

Anuncios

Responses

  1. ¡EXITO ABSOLUTO!

    Genial, mil gracias. Con Ubuntu 6.06 no fui capaz de hacer funcionar beryl (creo q era algun tema de driver fglrx), pero con el nuevo Edgy y tu sencillo tutorial, todo ha sido extremadamente simple.

    Muchas gracias de nuevo 🙂

  2. Hola. Estaria encantado de que me pudieses ayudar. Llevo tres meses en esto de Ubuntu. Tenia la 6.6 y la he actualizado a la 6.10. Con la 6.6 intenté la aceleracion 3D y no pude: Al reiniciar me daba error de configuración Xserver. Tuve que reinstalar. Ahora con la 6.10 me he animado otra vez.(No tengo 3D) He querido instañar Beryl siguiendo tus pasos. Al llegar al punto 4, reinicio. Aparece el gestor de arranque dandome opción de iniciar Ubuntu en sus diferentes versiones o Windows. Le indico que arranque Ubuntu. Aparece la primera pantalla. Carga todo y es cuando me va a pedir el usuario cuando me da el dichoso error: Error al iniciar Xserver, debe estar mal configurado y no arranca.
    Gracias que hice una copia de xorg.conf original. En la poción de arranque opto por la de “emergencia” y sustituyo el xorg.conf por el que tenia con cp.
    Ahora me arranca, bien.
    Gracias y haber si me puedes ayudar

  3. Hola Fernando. Antes de lanzarte a instalar Beryl trata de obtener la aceleración 3D como comento en el hilo:

    https://cmaverick.wordpress.com/2006/10/26/aceleracion-3d-con-ati-en-edgy/

    A ver si tienes suerte.

  4. Hola otra vez. Impecable. Aceleración 3D cojonuda. GRACIAS. Mas adelante, con tranquilidad, instalaré Beryl. De momento quiero disfrutar de esta aceleración. Gracias otra vez. Ya te comentaré algo.

  5. Hola otra vez. Como te dije, la Aceleración 3D OK. Pero cundo voy ejecutar Beryl me aparece esto en consola:

    fernando@fernando-desktop:~$ sudo apt-get install beryl emerald emerald-themes
    Password:
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo información de estado… Hecho
    beryl ya está en su versión más reciente.
    emerald ya está en su versión más reciente.
    emerald-themes ya está en su versión más reciente.
    Los siguientes paquetes fueron instalados automáticamente y ya no son necesarios:
    libk3b2 libexiv2-0.10 libflac++5c2 liblog4j1.2-java libseda-java
    libcommons-cli-java libgtk-jni libcairo-java libswt3.1-gtk-java
    libswt3.1-gtk-jni kdebase-bin libglib-java libdbus-qt-1-1c2 libgtk-java
    dpatch
    Use «apt-get autoremove» para desinstalarlos.
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    fernando@fernando-desktop:~$ beryl-manager
    fernando@fernando-desktop:~$ XGL Absent, checking for NVIDIA
    Nvidia Absent, assuming AIGLX
    beryl: No composite extension

    La pantalla me da saltos y al final se queda OK. La Emerald la tengo en la oparte superior, y la CPU al 100%.
    Salgo de la Emerald y la CPU se estabiliza. Tengo una ATI X550. A ver si pudes saber que pasa. No se si me estoy tomando demasiada confianza. Gracias y enhorabbuena por los resultados de tu blog.

  6. Hola a mi me pasa exactamente lo mismo y me da el mismo error ke a fernando
    y yo tambien tengo una ati x550 sera por la grafica???

  7. id paso a paso, sin aceleración 3d beryl no funciona, sin xgl o aigxl tampoco. Animo que no es complicado. Una vez actualizais los repos podeis instalarlo todo desde synaptic.

  8. yo me uno a ustedes a mi me pasa igual y tengo una x1800xl. ya no se que hacer no lo he podido instalar y llebo muchas reiniciadas y formateadas pero nada

  9. Gracias. Todo muy bien explicado y me ha funcionado a la primera, aunque tengo un problema: Al mover una ventana o rotar el cubo tengo “tearing” y se hace muy incómodo. Parece que no me hace el vsync aunque está activado. ¿Alguna idea?

  10. ¡Hola!
    Yo tengo una MobilityRadeon X1600 y después de instalarlo todo el Beryl se me ejecuta, aparece el icono en 2º plano y al intentar elegir Beryl como gestor de ventanas se me va al Metacity (que está puesto en la opción “Lanzar … si Beryl falla”). Desde la consola tengo el mismo error que el resto:

    >

    Lo he intentado con Ubuntu 6.06, con Kubuntu 6.06 y con Ubuntu 6.10… ¿Alguna idea/solución?

    Muchas gracias de antemano. Xau

  11. Siento escribir otro post seguido, pero como el error de la consola no aparece… Repito, el error es idéntico al de Fernando:
    >

    Xau

  12. Vaya, escribo por tercera vez (creo que el fallo está en poner los mayor que y menor que en el post, por el HTML).

    Lo siento Maverick 😥

    Por favor, ayudadme con esto, estoy desesperado.

    Mil gracias; xau

  13. Pues por aca el mismo problema..
    Innstalacion freska de Ubuntu edgy …
    seguido el tuto al pie de la letra…

    resultados:

    Nada de beryl… menudo koñazo!!
    A esperar que Ati & Beryl se acuerden de nosotros.. los que poseemos una Ati x1XXX

    Porque la verdad ya estoy cansado de segir 1000 tutos y con ninguno furula…

    Saludos..

    Pdt.. Dios Salve a Quinnstorm.. porque sin este nunca hubiera podido probar un ·d desktop en condiciones.

  14. mi problema es el mismo cuando intento activar beryl me da el error ese de nvidia nose que y se desactiva direct rendering despues del reinicio….el problema yo diria que es el direct rendering pero…como volverlo a activar?

  15. siento volver a escribir seguido mi t.g. es ati pro jeje gracias espero respuestas 😉

  16. Si tengo aceleracion 3D con hecha con el manual que tienes en tu blog, es necesario que instale los drivers libres de ati?

  17. Si, sigue los pasos uno a uno y deberías tener Beryl sin problemas.

  18. vale, voy a hacerlo y te cuento

  19. Maverick de ante mano muchas gracias por todo.

    Tengo una ati X1600 y me vuelto loco intentandolo y al final lo he conseguido con este turotial

    http://lhansen.blogspot.com/2006/10/3d-desktop-beryl-and-xgl-on-ubuntu-edgy.html

    esta en inglés pero merece la pena.
    Si después os da errores de parpadeo los bordes de las ventanas agregar en el inicio de la sesion emerald

  20. jejeje ya tengo el beryl instalado (ahora no se que hacer pero bueno). El tema es que cuando voy a cambiar de theme con el gestor de themes, me da este errror: You need Subversion package installed
    to use this feature.

    Como lo soluciono?

  21. Me he dado cuenta que después de haber seguido unos 200 tutoriales te piensas que funcionó el ultimo, pero no es asi,
    me funcionó una mezcla, espero que esta vez os indique bien los pasos.
    1- he añadido al repositorio todo lo que viene en esta página

    http://www.ubuntu-es.org/index.php?q=node/29492

    He seguido los pasos de este turorial para conseguir la aceleracion con los driver originales de ATI

    http://forums.cjb.net/ubuntu-about62.html

    y por último he seguido este tutorial para que funcione Beryln

    http://forums.cjb.net/ubuntu-about62.html

    Espero que os sirva y que funcione porque me he vuelto loco para que me funcione a mi porque soy totalmente novato en Linux.

  22. Ati radeon 9550/x1050 series… ubuntu edgy driver instalado ati propietario 8.34.8 descargado de la página de ati… hice los paquetes para ubuntu los instale compile el kernel para los modulos y listo!!!

    glxinfo | grep direct ===>> direct rendering: Yes
    fglrxinfo ===>display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: RADEON 9550/X1050 Series
    OpenGL version string: 2.0.6334 (8.34.8)

    ok tengo aceleración 3D… creo una sesion para xgl ok… listo
    glxgears -printfps… se queda pegado, es decir, se cae y debo reiniciar, pero no importa… isntalemos beryl…

    Lo instale hace unos días y funcionaba, algo lento pero bien y se me ocurrio acutalizarlo al svn… no funko haci que saque esos repositorios (los de treviño) y deje solo el de beerorkid desistale e instale beryl estable….

    Como es tipico rompi la regla de oro “si funciona no lo toques”, pero “sin riesgo no hay diversion”… y ahora no funciona… es decir… inicia la sesion xgl y se muestra el splash de beryl levanta unos segundos y se reinicia, es decir, me cierra la session… que puede ser???
    Para iniciar la sesion tengo esto:

    Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLA$
    cookie=”$(xauth -i nextract – :0 | cut -d ‘ ‘ -f 9)”
    xauth -i add :1 . “$cookie”
    # Iniciar Gnome
    exec gnome-session

    Agradeceria cualquier ayuda… ya me he currado harto y mi cerebro no se le ocurre otra idea…

    Gracias de antemano
    msdarkici@gmail.com
    http://msdark.wordpress.com

  23. hola, espero que me puedan ayuar con esta duda:

    Acabo de instalar beryl y tengo el emerald themer, al cual le tuve que poner una subversion para q me dejara “aplcar los temas”. El problema es que al elegir un tema, simplemente no hace nada, no aplica ningun tema y tampoco me marca error.

    Si alguien sabe la soluciòn, se los agradeceìa mucho

    saludos

  24. En esta web hay un manual de como configurar la ati en ubuntu. Según ellos es el manual definitivo y la verdad que yo con una ati radeon 200M, que no la habia conseguido configurar con ningun manual, con los pasos de esta web lo he conseguido. Y siguiendo los manuales de la misma web, he conseguido instalar beryl y tengo el cubo 3d y todo.

    Os la recomiendo a los que tengais problemas… ami me funcionó con mi tarjeta.

    Instalar driver ATI y Beryl en Ubuntu

  25. tengo ubuntu hace poco y no se como intalar beryl pe pueden mandar las indicasiones a mi mail (tal215@hotmail.com) porfa

  26. hola a todos acabo de instalar kubuntu 7.0 y ya tengo instalado los drivers de la placa de video , pero ahora no puedo instalar beryl en otros forors me dicen q baya a synaptic escriba beryl y listo pero ni siquiera encuentro synaptic, agradeceria si alguien me puede explicar muchas gracias soy nuevo en esto y no entiendo nada

  27. Hola tengo el ubuntu con el beryl insatalado pero cuando lo pongo para girarlo y dejar otro escritorio, a la hora de que vuelva el escritorio el cubo se queda fijo y ya no puedo hacer nada y he de reiniciar el ordenador, alguien podria ayudarme con este fallo, gracias.

  28. hola
    soy nuevo en esto lo que mis amigos y yo le llamamos la nueva era… ” software libre ” es mas hasta persuadimos a nuestros compañeros a unirse a esto…

    pero lo cierto es que soy my inesperto en esto pero la verdad quiero aprender a menejar mi compu como los grandes ….

    estoy enterado de las maravillas de beryl mi problema es como empezar con el proceso de instalacion o que debo tener …

    tengo una maquina con ubuntu 6.6 ya esta funcionando muy bein,,, ahora que hago pues quiero poner beryl en mi maquina y agradeceria mucho la ayuda ….

    atte: lord remek

  29. lord remek el blog se encuentra es http://www.elblogdemaverick.com

  30. Hla… ya tengo aceleracion con una ATI 200M (me doy cuenta por los screensavers…)
    pero no hay manera de cargar el beryl???

    Ayuda please….
    gracias


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Categorías

A %d blogueros les gusta esto: